Contact Us

Required Firmware Update for Teradek Devices

In Spring 2018, we will be making backend security updates to the Livestream platform due to a PCI compliance mandate. This change will shut down support for older SSL and TLS protocols and is expected to take effect no later than June 30, 2018, per Fastly’s TLS deprecation timeline.

  

How does this impact me?

  

If you are using an older Teradek encoder, you need to update your device’s firmware. Devices that we know will be impacted are:

 

  • Cube (1st and 2nd generation)

  • Slice (1st generation)

  • Bond, Bond II, and Bond Pro

  • T-Rax (1st generation)

 

Teradek has provided links to download the newest firmware versions in its support center

 

If you do not update your firmware, you will not be able to log in to your Livestream account or go live to your Livestream events via your Teradek device.


If you have any questions or concerns about this, please do not hesitate to contact us.

Have more questions? Submit a request