Contact Us My Activity Community

Why is Internet Explorer Saying I Need To Upgrade My Browser?

Internet Explorer users should be aware that Livestream recommends version 11 only. Please see Microsoft's statement regarding older versions of Internet Explorer.

 

If you're using Windows 7, or 8 with the default Internet Explorer browser, you may see a window asking you to upgrade your browser.

Why does this happen for Internet Explorer?

This occurs on Internet Explorer's compatibility view which may be set to Legacy on version 11 by default. However, since older versions of Internet Explorer are not supported by Livestream, this message may pop up.


Please follow these steps to remove: 

  • Press the Alt key to display the menu bar.
  • Click the Tools menu and choose Compatibility View Settings.
  • From the list of "Websites you've added to Compatibility View", highlight 'livestream.com.'
  • Click Remove.

Microsoft provides instructions here as well.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.